Problem with application

Discussion in 'Coast Guard Academy - USCGA' started by kl3661, Apr 27, 2014.

  1. kl3661

    kl3661 Member

    Joined:
    Mar 30, 2014
    Messages:
    67
    Likes Received:
    6
    I requested for information on the USCGA website (i was thinking that's how you join the mailing list) and they told me to create a bear's den account so I did
    I was curious what the application looked like so I clicked on application (I think it's for class of 2019 but I'm not sure) and now on the admissions checklist on the right it says application started although I'm a sophomore at high school and I'm not eligible yet
    So I went back to applications and now it's telling me there was a problem and I should log out and log in again and close all windows
    And it says it still has the problem

    Should I contact the admissions to tell the the problem or should I just leave it until it's time for me to apply

    And if I should contact someone who should I contact?

    Thanks so much

    Sent using the Service Academy Forums® mobile app
     
  2. matty

    matty Member

    Joined:
    Mar 8, 2014
    Messages:
    186
    Likes Received:
    26
    Hey dude.

    I did the same thing a while ago.

    Don't sweat it. They reset the application process every year, so by the time you apply, there should be a brand new "start application" button.

    If possible, can the Objee "alias" help clarify this in more depth? Thanks.
     
  3. grevar

    grevar CGA Admissions Partner

    Joined:
    Mar 5, 2013
    Messages:
    517
    Likes Received:
    111
    The application for the class of 2019 probably won't open until August. Anything you input now won't be worth anything so don't waste your time.
     
  4. kl3661

    kl3661 Member

    Joined:
    Mar 30, 2014
    Messages:
    67
    Likes Received:
    6
    Thanks so much

    Sent using the Service Academy Forums® mobile app
     

Share This Page