AFROTC Application Issue

calebaudia

New Member
Joined
Jul 10, 2021
Messages
3
Hey Guys! I hope you are all doing well. This is my first post on the Service Academy Forums, so please bear with me if I make some mistakes, I apologize ahead of time. Okay, so I'm aware that the AFROTC portal opened up July 1, and I was looking forward to filling some of it then and trying to get as much of a head start that I would be allowed to do. However, upon logging in, and pulling up the application, it states that the "application date" is 10/31/2020. I'm assuming this means I still have last year's application and not the 2021 updated version.

I did create an account last year, and yes, I made the mistake of opening it to see if I could go ahead and prepare with documentation prior to this year's opening. I assumed that, since I wouldn't be awarded the scholarship for not filling it out, it would've closed my previous application and have me do it again.

I am currently heading into my senior year of high school, I have contacted the HOLM Help center multiple times, yet, nothing seems to come out of anything. It's been 10 days, and I'm practically itching through my skin as I feel as if I'm falling a bit behind, and I definitely do not feel comfortable with the situation since I haven't heard back from them in around 5-6 days, even after sending more emails. Just curious to see if anyone's had this issue before, and could maybe give me a direction to work towards getting this issue fixed. Thank you all for your time, please ask me any questions if you have any!

Also, I attached a screenshot of what I see on my end. I know I'm not seeing the correct things, however, because I have a really close friend who is also going through her sign-up, and it looks quite different. Hope it helps.
 

Attachments

  • Screen Shot 2021-07-02 at 7.08.02 PM.png
    Screen Shot 2021-07-02 at 7.08.02 PM.png
    102 KB · Views: 21

calebaudia

New Member
Joined
Jul 10, 2021
Messages
3
Can you create a new account using a different email?
I have tried that, and they even reset my account with the same email, but those options didn't work as I believe it could be tied to my SSN, name, and birthdate combination (which makes sense so that individuals cannot fill out more than one application).
 

kinnem

Moderator
10-Year Member
Joined
Oct 21, 2010
Messages
14,806
I have tried that, and they even reset my account with the same email, but those options didn't work as I believe it could be tied to my SSN, name, and birthdate combination (which makes sense so that individuals cannot fill out more than one application).
Did you clear out the cache in your browser?
 

calebaudia

New Member
Joined
Jul 10, 2021
Messages
3
Did you clear out the cache in your browser?
Yes sir. I even tried it on a different computer and even a different search engine. I've used Safari, Google & Internet Explorer, clearing the browsing data and cache each time. Still no luck, unfortunately.
 

kinnem

Moderator
10-Year Member
Joined
Oct 21, 2010
Messages
14,806
Hmmmm.... no idea how to fix it except to continue working with the Help Center
 

kinnem

Moderator
10-Year Member
Joined
Oct 21, 2010
Messages
14,806
Yes sir. I even tried it on a different computer and even a different search engine. I've used Safari, Google & Internet Explorer, clearing the browsing data and cache each time. Still no luck, unfortunately.
Did you clear the cache and then close the browser? It may be remembering stuff in the session. It's also possible, when you tried the other computer, that it thought you were restoring the existing session. Try clearing the cache and closing the browser. Then wait an hour before trying again. Don't know if this will fix it but it's worth trying if you haven't already corrected the problem.
 

jaglvr

Member
Joined
Dec 23, 2017
Messages
1,340
Hey Guys! I hope you are all doing well. This is my first post on the Service Academy Forums, so please bear with me if I make some mistakes, I apologize ahead of time. Okay, so I'm aware that the AFROTC portal opened up July 1, and I was looking forward to filling some of it then and trying to get as much of a head start that I would be allowed to do. However, upon logging in, and pulling up the application, it states that the "application date" is 10/31/2020. I'm assuming this means I still have last year's application and not the 2021 updated version.

I did create an account last year, and yes, I made the mistake of opening it to see if I could go ahead and prepare with documentation prior to this year's opening. I assumed that, since I wouldn't be awarded the scholarship for not filling it out, it would've closed my previous application and have me do it again.

I am currently heading into my senior year of high school, I have contacted the HOLM Help center multiple times, yet, nothing seems to come out of anything. It's been 10 days, and I'm practically itching through my skin as I feel as if I'm falling a bit behind, and I definitely do not feel comfortable with the situation since I haven't heard back from them in around 5-6 days, even after sending more emails. Just curious to see if anyone's had this issue before, and could maybe give me a direction to work towards getting this issue fixed. Thank you all for your time, please ask me any questions if you have any!

Also, I attached a screenshot of what I see on my end. I know I'm not seeing the correct things, however, because I have a really close friend who is also going through her sign-up, and it looks quite different. Hope it helps.
The check area for air force or space force is new. It was not on my DD's application screen last year.
 
Top